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1 Introduction

This chapter provides an introduction to MerlinPlus.

In this chapter:
Overview
Installation
Selecting the Device Number
Viewing the Firmware Revision
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Overview
MerlinPlus is a Windows based GUI test and simulation program for MIL-STD-
1553, MIL-STD-1760 and MMSI data buses. MerlinPlus supports BC/Concurrent 
RT, Remote Terminal and Sequential Monitor modes. Error injection and error 
detection are also supported.
If you have more than one 1553/1760/MMSI module, you can run each module in 
a different mode simultaneously. So you can send data from one module, and view 
the data being received on the other module in real time.
MerlinPlus is built around the 1553Px Family Software Tools, enabling the use of 
a single executable for multiple boards and operating systems. 

Installation
MerlinPlus is installed together with the all the necessary DLLs for the 
appropriate boards. At the end of the MerlinPlus installation, ExcConfig is run. 
Use ExcConfig to assign a device number to the board. For instructions, see 
Assigning a Device Number to the Board in Installation Instructions.pdf. This file is located 
in the root folder of the installation CD.

Selecting the Device Number
To select your device number:

1. From the Windows Start menu, select MerlinPlus. The MerlinPlus main 
screen is displayed.

 Figure 1-1 MerlinPlus Main Screen

2. From the main screen menu bar, select Setup, select your board type > Device #.
The Select device number dialog box is displayed.
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 Figure 1-2 Select Device Number Dialog Box

3. In the Device field, type the device number of your board. (This is the device 
number that was assigned to the board using the ExcConfig utility.)

4. Click OK.
The status bar indicates (1) the board initialization status, (2) the number of 
modules detected, (3) the firmware revision number of each module, (4) the 
board type and (5) the device number of the board.

 Figure 1-3 MerlinPlus Main Screen with Board Loaded

Viewing the Firmware Revision
To view the firmware revision:

• From the main screen menu bar, select File > Firmware Revision Information. 
The firmware information is displayed. 
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2 Bus Controller/Concurrent RT Mode

In Bus Controller/Concurrent RT Mode, the module simulates the Bus Controller 
and up to 32 Remote Terminals. (On single function PxS modules, RT simulation 
is not available.)

In this chapter:
The BC/Concurrent RT Mode Screen
Setting Global Options for BC/Concurrent RT Mode
Defining Messages
Adding/Duplicating a Message in the Message List
Clearing Messages
Using Minor Frames
Using Error Injection
Setting Retries
Saving/Loading the BC/Concurrent RT Mode Configuration
Starting/Stopping BC/Concurrent RT Mode
Viewing Message Details
Restarting the Module
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The BC/Concurrent RT Mode Screen
To open the BC/Concurrent RT Mode screen:

• From the main screen menu bar, select Modules/Banks > Module/Bank # > 
BC/Concurrent RT Mode.
The BC/Concurrent RT Mode screen is displayed. The Define Messages tab 
shows the currently defined messages (if any). The fields are described in 
Table 2-1.

Figure 2-1 BC/Concurrent RT Mode Screen

Field Description

No. Message number.

Gap (microsec) Intermessage gap in μsec (minimum 4 μsec).

From Message from either BC or RT/subaddress.

To Message to either BC or RT/subaddress.

CW Command Word of the message.

CW2 Second Command Word of the message for RT to RT 
message.

WC Word Count. Number of Data Words in the message.

Bus
(not for MMSI)

Bus on which to transmit.

Retries Number of times to resend the message in the event that the 
RT does not respond without the timeout period. See Setting 
Retries on page 2-15.

Table 2-1 BC/Concurrent RT Mode Screen
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Setting Global Options for BC/Concurrent RT Mode
The Global Setup tab of the BC/Concurrent RT Mode screen contains general 
option in BC/Concurrent RT Mode.

To set global options for BC/Concurrent RT Mode:

1. From the main screen menu bar, select Modules/Banks > Module/Bank # > 
BC/Concurrent RT Mode.
The BC/Concurrent RT Mode screen is displayed.

Figure 2-2 BC/Concurrent RT Mode Screen

2. Click the Global Setup tab.

Err Inj Type of error injection selected. See Using Error Injection on 
page 2-15.

Msg/Err Cnt Running count of messages and errors.

Chk Sum
(1760 and MMSI 
only)

Whether the last Data Word of the message is a checksum.

Field Description

Table 2-1 BC/Concurrent RT Mode Screen (Continued)



Chapter 2 Bus Controller/Concurrent RT Mode

page 2 - 4  Excalibur Systems

Figure 2-3 BC/Concurrent RT Mode Screen – Global Setup Tab

3. Complete the fields, as described in Table 2-2.

Field Description

Frame Time Amount of time in μsecs between the start of the transmission of 
a frame and the next transmission of this frame. A frame is the 
entire list of messages that are defined on the Define Messages 
tab of the BC/Concurrent RT Mode screen (Figure 2-1). When all 
the messages in the frame are transmitted, MerlinPlus waits until 
the end of the frame time to transmit them again. If MerlinPlus is 
set to transmit only once, this field is not relevant. See Type of 
Run.
Note: When using minor frames, you usually want to enter a 
lower value for Frame Time than the Minor Frame Time, so that 
the Minor Frame Time controls all the timing, and MerlinPlus 
does not wait after the last minor frame before transmitting 
again.

Bit Count Error Number of bits to add to or subtract from the Command Word 
or the data, when using Incorrect Bit Count as Error Injection 
(+3 to –3).

Output Amplitude Output amplitude in milliVolts peak-to-peak (1000–7500, default 
7500).

BC Response Time Bus Controller response time in μsecs (4–32, default 14). This 
is the maximum wait time until an RT’s status response is 
considered invalid by the BC.

Word Count Error Number of words to add to or subtract from the Word Count, 
when using Incorrect Word Count as Error Injection (+3 to –3).

Table 2-2 BC/Concurrent RT Mode Screen – Global Setup Tab
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Minor Frame Time Amount of time in μsecs between the start of the transmission 
of one minor frame and the start of the transmission of the next 
minor frame. A minor frame is the list of messages that follow a 
minor frame row on the Define Messages tab of the 
BC/Concurrent RT Mode screen. See Using Minor Frames on 
page 2-14.

Active RT list Select which RTs to activate by clicking the desired RT 
numbers or by clicking All Active. To deselect all RTs, click 
No Active.

Type of Run Type of transmission:
• One shot – transmit the message list once. 
• ‘N’ times – transmit x times; type the number of times in the 

text box (1–255).
• Continuous – continue transmitting in a loop until selecting 

Run > Stop.

Broadcast Enabled 
(RT 31)

Whether to enable broadcast on RT 31.

1760 Header 
Word Options
(1760 and MMSI 
only)

Whether messages will have a 1760 Header Word:
• Suppress/Disable the Feature
• User will set Header Word

Hub Mode
(MMSI only)

Type of Hub Mode:
• Switch mode
• Link mode
• Spec mode

SRQ Processing Whether to enable SRQ processing.

Field Description

Table 2-2 BC/Concurrent RT Mode Screen – Global Setup Tab (Continued)
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Defining Messages
To define a message:

1. From the main screen menu bar, select Modules/Banks > Module/Bank # > 
BC/Concurrent RT Mode. 
The BC/Concurrent RT Mode screen is displayed.

Figure 2-4 BC/Concurrent RT Mode Screen 

2. Double-click the first blank row (or any defined message) in the columns 
Gap, From, To, CW, CW2, WC or Bus.
The Define Message dialog box is displayed.

Figure 2-5 Define Message Dialog Box
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3. On the left side, select the message type (BC > RT, RT > BC, RT > RT, Mode 
(Mode Codes), or Minor Frame), then complete the fields, as described below.
Continue with the desired message type:
• BC to RT Messages on page 2-7
• RT to BC Messages on page 2-10
• RT to RT Messages on page 2-11
• Mode Code Messages on page 2-12

BC to RT Messages
a. Complete the fields, as described in Table 2-3.

Figure 2-6 Define Message Dialog Box – BC to RT Message

b. To set the message data, click Data. 

Field Description
Destination RT Destination RT number.

Destination Sub Destination subaddress.

Gap (microsec) Intermessage gap in μsec (minimum 4 μsec).

Word Count Number of Data Words in the message.

Bus
(not for MMSI)

Bus on which to transmit.

Checksum
(1760 and MMSI 
only)

Whether the last Data Word of the message is a 
checksum.

Table 2-3 Define Message Dialog Box – BC to RT Message
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The Define/Modify Data dialog box is displayed.

Figure 2-7 Define/Modify Data Dialog Box

c. You can enter hex data for each Data Word, up to the amount of words 
specified in the Word Count field on the previous dialog box.
– OR – 
You can also use the options described in Table 2-4.

Button Description

Data Generator Opens the Data Generator dialog box, to 
define dynamic data for the selected Data 
Word. When using the Data Generator, 
different data is transmitted each time this Data 
Word is transmitted. See Step d on page 2-9.
Note: When Data Generator is enabled, the 
Data Word is gray. If there is a value in that 
Data Word, it will be ignored.

Clear Clears the data of all Data Words.

Default Enters values for all Data Words starting from 
0 and incrementing each Data Word by 1.

1 > All Copies the value of the first Data Word to all 
other Data Words.

Load Loads previously saved values.

Save Saves the values of all Data Words for later 
use.

Random Enters random values for all Data Words.

Table 2-4 Define/Modify Data Buttons
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d. (Optional) To use the Data Generator, click Data Generator.
The Data Generator dialog box is displayed.

Figure 2-8 Data Generator Dialog Box

e. Complete the fields, as described in Table 2-5, then click OK.

f. Click OK in the Define/Modify Data dialog box.
g. Click OK in the Define Message dialog box.

Field Description

Disable / Enable Enables or disables the Data Generator.

Increment / 
Decrement

Whether to increment or decrement the value 
with each transmission of the Data Word.

Increment by Value in decimal to increment or decrement by.

Start Value Starting value in decimal.

End Value Ending value in decimal. When the data 
reaches the end value, it loops back to the start 
value.

OK Saves the data and returns to the 
Define/Modify Data dialog box.

Apply Saves the data and remains in the Data 
Generator dialog box.

Reset Restores the values to the values at the time 
the Data Generator was opened.

Clear Restores all values to their defaults.

Table 2-5 Data Generator Dialog Box
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RT to BC Messages
• Complete the fields, as described in Table 2-6, then click OK.

Figure 2-9 Define Message Dialog Box – RT to BC Message

Field Description

Source RT Source RT number.

Source Sub Source subaddress.

Gap (microsec) Intermessage gap in μsec (minimum 4 μsec).

Word Count Number of Data Words in the message.

Bus
(not for MMSI)

Bus on which to transmit.

Checksum
(1760 and MMSI 
only)

Whether the last Data Word of the message is a 
checksum.

Table 2-6 BC to RT Message



Chapter 2 Bus Controller/Concurrent RT Mode

MerlinPlus User’s Manual page 2 - 11

RT to RT Messages
• Complete the fields, as described in Table 2-7, then click OK.

Figure 2-10 Define Message Dialog Box – RT to RT Message 

Field Description

Source RT Source RT number.

Source SA Source subaddress.

Destination RT Destination RT number.

Destination SA Destination subaddress.

Gap (microsec) Intermessage gap in μsec (minimum 4 μsec).

Word Count Number of Data Words in the message.

Bus
(not for MMSI)

Bus on which to transmit.

Checksum
(1760 and MMSI 
only)

Whether the last Data Word of the message is a 
checksum.

Table 2-7 BC to RT Message
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Mode Code Messages
• Complete the fields, as described in Table 2-8, then click OK.

Figure 2-11 Define Message Dialog Box – RT to BC Message

Field Description

Source RT
(not for Mode 
Codes 17, 20 or 
21)

Source RT number.

Destination RT
(for Mode Codes 
17, 20 and 21 only)

Destination RT number. 

Mode Code 
Designation

Bit sequence in a subaddress that indicates that the 
message is a mode code:
• All 0’s – All 0’s specifies a mode code
• All 1’s – All 1’s specifies a mode code

Mode Command The selected Mode Code (0-8,16-21)

Gap (microsec) Intermessage gap in μsec (minimum 4 μsec).

Word Count Number of Data Words in the message.

Bus
(not for MMSI)

Bus on which to transmit.

Checksum
(1760 and MMSI 
only)

Whether the last Data Word of the message is a 
checksum.

Table 2-8 BC to RT Message
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Adding/Duplicating a Message in the Message List
You can add a new message or a minor frame in middle of the list of messages. 
When you add a message, the selected message is duplicated. Then you can edit 
it, change the type of message or make it a minor frame. 

To add a message in middle of the list:

1. From the main screen menu bar, select Modules/Banks > Module/Bank # > 
BC/Concurrent RT Mode. 
The BC/Concurrent RT Mode screen is displayed.

Figure 2-12 BC/Concurrent RT Mode Screen

2. Double-click a message number in the left-hand column, then click Add Row.
The message is duplicated.

3. Edit the new message. See Defining Messages on page 2-6.

Clearing Messages
To delete a single message from the list:

• On the Define Messages tab of the BC/Concurrent RT Mode screen 
(Figure 2-1), double-click a message number in the left-hand column, then 
click Delete Row.
The message is deleted.

To delete all messages:

1. On the BC/Concurrent RT Mode screen (Figure 2-1), select Run > Stop (or 
press F4).
MerlinPlus stops transmitting messages.
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2. Select File > Clear Screen.
All messages are deleted. These messages are only cleared on the screen, 
but are not cleared from the memory of the board. New messages will be 
entered into the memory of the board when you select Run > Start.

Using Minor Frames
Use minor frame messages to group messages – one before the start of each new 
group – to ensure that the next group of messages will not start transmission 
until the full minor frame time has elapsed. The minor frame time is set on the 
Global Setup tab (see Figure 2-3).
When using minor frames, the first message must be a minor frame message, and 
the last message should not be a minor frame message.

To add a minor frame:

1. From the main screen menu bar, select Modules/Banks > Module/Bank # > 
BC/Concurrent RT Mode. 
The BC/Concurrent RT Mode screen is displayed.

Figure 2-13 BC/Concurrent RT Mode Screen 

2. Double-click the first blank row.
The Define Message dialog box is displayed (Figure 2-5).

3. Click Minor Frame, then click OK.
The minor frame is added to the list of messages on the BC/Concurrent RT 
Mode screen. The messages that follow the minor frame are part of the 
minor frame, until the next minor frame message or until the end of the bus 
list.
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Using Error Injection
Note: Error injection is not available for single function PxS modules.

To use error injection:

• On the Define Messages tab of the BC/Concurrent RT Mode screen 
(Figure 2-1), right-click the row of the desired message, select Error Injection, then 
select the desired error type.
The selected error injection type is displayed in the Err Inj column.

Setting Retries
You can set retries for a message. When you set retries, MerlinPlus will resend 
the message in the event that the RT does not respond within the timeout period 
specified in the BC Response Time field on the Global Setup tab of the 
BC/Concurrent RT Mode screen (Figure 2-3). You can set up to 3 retries, and 
specify whether the retires should be on the same bus or to alternate between 
buses with each retry.

To set retries:

• On the Define Messages tab of the BC/Concurrent RT Mode screen 
(Figure 2-1), right-click the row of the desired message, select Retries, then 
select the desired number and type of retries.
The selected number of retries is displayed in the Retries column. When you 
select retries on alternate buses, the number is displayed as a negative 
number.

Saving/Loading the BC/Concurrent RT Mode Configuration
You can save the BC/Concurrent RT Mode configuration to a file and load the file 
later. The file includes all defined messages and the settings defined on the 
Global Setup tab of the BC/Concurrent RT Mode screen (Figure 2-3).

To save the BC/Concurrent RT Mode configuration:

1. On the BC/Concurrent RT Mode screen (Figure 2-1), select File > Save Parame-
ters.
The Save BC Messages dialog box is displayed.
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Figure 2-14 Save BC Messages Dialog Box 

2. Select a location to save the file.
3. In the File name field, type a name for the file.
4. Click Save.

The message file is saved.

To load a BC/Concurrent RT Mode configuration file:

1. On the BC/Concurrent RT Mode screen (Figure 2-1), select File > Load Parame-
ters.
The Load BC Messages dialog box is displayed.

Figure 2-15 Load BC Messages Dialog Box

2. Select an MMF file, then click Open.
The messages are displayed file on the Define Messages tab of the 
BC/Concurrent RT Mode screen (Figure 2-1).
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Starting/Stopping BC/Concurrent RT Mode
You can start/stop BC/Concurrent RT simulation at any time. When you start 
BC/Concurrent RT simulation, the messages that you defined are transmitted 
over the bus.

To start message transmission:

• On the BC/Concurrent RT Mode screen (Figure 2-1), select Run > Start (or 
press F9).
MerlinPlus starts transmitting messages.

To stop message transmission:

• On the BC/Concurrent RT Mode screen (Figure 2-1), select Run > Stop (or 
press F4).
MerlinPlus stops transmitting messages.

Viewing Message Details
You can view messages in real time.

To view message details:

• On the Define Messages tab of the BC/Concurrent RT Mode screen 
(Figure 2-1), double-click a message in the Msg/Err Cnt column.
The BC Message Information dialog box is displayed.

Figure 2-16 BC Message Information Dialog Box
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The Message Information screen shows the details of the message in the 
selected row on the Define Messages tab of the BC/Concurrent RT Mode 
screen. In BC/Concurrent RT Mode, the Message Information screen always 
shows details about the same message, but it is updated in real time each 
time the module transmits the message.
The top part of the screen displays the Command Word(s) and RT Status 
Word(s) of the completed message. The middle part displays the data. And 
the bottom part displays the Message Status Word that Excalibur stores for 
each message. 
The Message Status Word contains information about the completed 
message, including error information. The bits of the Message Status Word 
vary depending on the mode (BC/RT, RT or Sequential Monitor). For details 
on the Message Status Word in BC/Concurrent RT Mode, see 
Get_Msgentry_Status_Px in the 1553Px Family Software Tools Programmer’s 
Reference.
You can click Previous or Next to view the previous or next message. When 
there is no previous or next message, clicking these buttons closes the dialog 
box.

Restarting the Module
To restart the module:

• On the BC/Concurrent RT Mode screen (Figure 2-1), select Run > Restart (or 
press F3).
The module is stopped and restarted, and all message and error counts are 
set to 0.
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3 Remote Terminal Mode

In Remote Terminal (RT) Mode, the module simulates up to 32 RTs. (For single 
function PxS modules, only one RT can be simulated at a time.) You can define 
each RTs response to BC commands, inject errors and load data for RT to BC and 
RT to RT messages. You can also view messages received by the RTs.

In this chapter:
The RT Mode Screen
Setting Global Options for RT Mode
Setting Per RT Options
Saving/Loading the RT Mode Configuration
Starting/Stopping RT Mode
Viewing Message Details
Viewing the Message and Error Count (RT Summary)
Clearing Messages
Restarting the Module
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The RT Mode Screen
To open the RT Mode screen:

• From the main screen menu bar, select Modules/Banks > Module/Bank # > 
RT Mode.
The RT Mode screen is displayed. When RT Mode is running, the Messages 
tab shows the messages received over the bus. Messages are updated in real 
time. The fields are described in Table 3-5. The Messages tab holds up to 
199 messages. Older messages are overwritten as new messages are 
received.

Figure 3-1 RT Mode Screen 

Setting Global Options for RT Mode
The Global RT tab of the RT Mode screen contains general option for RT Mode, 
that apply to all RTs.

To set global options for RT Mode:

1. From the main screen menu bar, select Modules/Banks > Module/Bank # > 
RT Mode.
The RT Mode screen is displayed. 
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Figure 3-2 RT Mode Screen

2. Click the Global RT tab.

Figure 3-3 RT Mode Screen – Global RT Tab



Chapter 3 Remote Terminal Mode

page 3 - 4 Excalibur Systems

3. Complete the fields, as described in Table 3-1.

Field Description

Active RT list Select which RTs to activate by clicking the desired RT 
numbers or by clicking All Active. To deselect all RTs, click 
No Active.

Errors to inject Errors to inject into the messages:
• Bit Count Error – incorrect bit count in the Data Words
• Non-contiguous Words – gap added between Data Words
• Status Parity Error – parity bit for the RT Status Word set 

incorrectly
• Status Sync Error – the sync pattern of the RT Status Word 

set incorrectly
• Data Parity Error – the parity bit for a Data Word set 

incorrectly
• Data Sync Error – the sync pattern of a Data Word set 

incorrectly
Note: Word Count Error is on the Per RT tab. See Setting Per 
RT Options on page 3-5.

Bit Count Error 
Value

Number of bits to add to or subtract from the standard 16-bit 
Data Word, when using Incorrect Bit Count as Error Injection 
(+3 to –3).

Output Amplitude Amplitude in millivolts peak-to-peak with which the RT will 
transmit Data and Status Words (1000–7500, default 7500).

Response Time Time in μsecs after which the RT will send a response (4–32).

Mode Code 
Designation

Bit sequence in a subaddress that indicates that the message 
is a mode code:
• Both 0’s and 1’s – All 0’s or all 1’s specifies a mode code
• All 0’s – All 0’s specifies a mode code
• All 1’s – All 1’s specifies a mode code

Broadcast Enabled 
(RT 31)

Whether to enable broadcast on RT 31.

1760 Header 
Word Options
(1760 and MMSI 
only)

Whether messages will have a 1760 Header Word:
• Suppress/Disable the Feature
• User will set Header Words

Hub Mode
(MMSI only)

Type of Hub Mode:
• Switch mode
• Link mode
• Spec mode

Table 3-1 RT Mode Screen – Global RT Tab
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Setting Per RT Options
The Per RT tab of the RT Mode screen contains options that apply to specific RTs.

To set Per RT options:

1. From the main screen menu bar, select Modules/Banks > Module/Bank # > 
RT Mode.
The RT Mode screen is displayed.

Figure 3-4 RT Mode Screen

2. Click the Per RT tab.

Figure 3-5 RT Mode Screen – Per RT Tab
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3. Complete the fields, as described in Table 3-2.

4. After selecting a data block for a transmit subaddress, right click on the 
subaddress to set the data.
The Define/Modify Data dialog box is displayed.

Field Description

RT Select the RT number to modify.

RT Status RT Address (returned) – RT number to return in the RT Status 
Word. By default, this is the same as the responding RT, 
selected in the RT drop-down box.
Bits to set in the RT Status Word:
• Message Error
• Service Request
• Instrumentation
• Broadcast
• Subsystem Flag
• Dynamic Bus
• Terminal Flag
• Busy

Word Count Error Number of words to add to or subtract from the word count 
(+3 to –3).

Set Vector Word Value to return in response to the transmitted Transmit Vector 
Word Mode command for the given RT.

BIT Word Value to return in response to the transmitted Built-in-Test (BIT) 
Word Mode command for the given RT.

Assign Blocks
(1760 and MMSI 
only)

Type of data blocks to assign:
• Standard Blocks – no checksum
• 1760 Checksum Blocks – data blocks with checksum

Click to assign 
data blocks to the 
selected Sub 
Address

Select each subaddress for which you would like to assign a 
specific data block. (A data block is a 32-word block of memory 
associated with one RT-subaddress-direction.) When you 
specify a data block for a receive subaddress, data sent to the 
selected subaddress (on the currently selected RT) will be 
saved in that data block. When you specify a data block for a 
transmit subaddress, the data to be transmitted from that 
subaddress will be taken from that data block.
When data is received at a subaddress that does not have a 
data block assigned, the data is stored in data block 0. 
Likewise, when data is transmitted from a subaddress that 
does not have a data block assigned, the data is taken from 
data block 0.
You can define up to 199 data blocks.

Table 3-2 RT Mode Screen – Per RT Tab
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Figure 3-6 Define/Modify Data Dialog Box

5. You can enter hex data for each Data Word, up to the number of words 
specified in the Word Count field on the previous dialog box.
– OR – 

You can also use the options described in Table 3-3.

Button Description

Data Generator Opens the Data Generator dialog box, to 
define dynamic data for the selected Data 
Word. When using the Data Generator, 
different data is transmitted each time this Data 
Word is transmitted. See Step 6 on page 3-8.
Note: When Data Generator is enabled, the 
Data Word is gray. If there is a value in that 
Data Word, it will be ignored.

Clear Clears the data of all Data Words.

Default Enters values for all Data Words starting from 
0 and incrementing each Data Word by 1.

1 > All Copies the value of the first Data Word to all 
other Data Words.

Load Loads previously saved values.

Save Saves the values of all Data Words for later 
use.

Random Enters random values for all Data Words.

Table 3-3 Define/Modify Data Buttons
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6. (Optional) To use the Data Generator, click Data Generator.
The Data Generator dialog box is displayed.

Figure 3-7 Data Generator Dialog Box

7. Complete the fields, as described in Table 3-4, then click OK.

8. Click OK in the Define/Modify Data dialog box.

Field Description

Disable / Enable Enables or disables the Data Generator.

Increment / 
Decrement

Whether to increment or decrement the value 
with each transmission of the Data Word.

Increment by Value in decimal to increment or decrement by.

Start Value Starting value in decimal.

End Value Ending value in decimal. When the data 
reaches the end value, it loops back to the start 
value.

OK Saves the data and returns to the Define/
Modify Data dialog box.

Apply Saves the data and remains in the Data 
Generator dialog box.

Reset Restores the values to the values at the time 
the Data Generator was opened.

Clear Restores all values to their defaults.

Table 3-4 Data Generator Dialog Box
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Saving/Loading the RT Mode Configuration
You can save the RT Mode configuration to a file and load the file later. The file 
includes the settings defined on all the tabs of the RT Mode screen, and the data 
defined for each RT-subaddress-direction.

To save the RT Mode configuration:

1. On the RT Mode screen (Figure 3-1), select File > Save Parameters.
The Save RT Parameters dialog box is displayed.

Figure 3-8 Save RT Parameters Dialog Box

2. Select a location to save the file.
3. In the File name field, type a name for the file.
4. Click Save.

The message file is saved.

To load an RT Mode configuration file:

1. On the RT Mode screen (Figure 3-1), select File > Load Parameters.
The Load RT Parameters dialog box is displayed.

Figure 3-9 Load RT Parameters Dialog Box

2. Select an RTP file, then click Open.
The RT parameters are loaded.
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Starting/Stopping RT Mode
You can start/stop RT simulation at any time. When you start RT simulation, the 
RTs that you activated on the module appear on the bus and respond to messages. 
When you stop RT simulation, the RTs that are defined in the module do not 
appear on the bus and any messages sent to those RT will result in errors.

To start RT Mode:

• On the RT Mode screen (Figure 3-1), select Run > Start (or press F9).
MerlinPlus starts running RT Mode.

To stop RT Mode:

• On the RT Mode screen (Figure 3-1), select Run > Stop (or press F4).
MerlinPlus stops running RT Mode.

Viewing Message Details
You can view messages details in real time.

To view messages:

1. On the RT Mode screen (Figure 3-1), click the Messages tab.
The RT Mode screen is displayed. When RT Mode is running, the Messages 
tab shows the messages received over the bus. Messages are updated in real 
time. The fields are described in Table 3-5.

Figure 3-10 RT Mode Screen – Messages Tab
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2. To view message details, double-click a message in the Error column.
The Message Information screen is displayed.

Figure 3-11 RT Message Information Screen

The Message Information screen shows the details of the message in the 
selected row on the Messages tab of the RT Mode screen. The Message 
Information screen is updated in real time as new messages are received.

Field Description

Num Message number.

Time (microsec) Timestamp of the message in μsec from the start of the 
module.

From Message from either BC or RT/subaddress.

To Message to either BC or RT/subaddress.

CW Command Word of the message.

CW2 Second Command Word of the message for RT to RT 
message.

WC Word Count. Number of Data Words in the message.

Bus
(not for MMSI)

Bus on which the message was transmitted.

Error Error status of the message.

Table 3-5 RT Mode Screen
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The top part of the screen displays the Command Word(s) and RT Status 
Word(s) of the completed message. The middle part displays the data. And 
the bottom part displays the Message Status Word that Excalibur stores for 
each message. 
The Message Status Word contains information about the completed 
message, including error information. The bits of the Message Status Word 
vary depending on the mode (BC/RT, RT or Sequential Monitor). For details 
on the Message Status Word in RT Mode, see Get_RT_Message_Px in the 
1553Px Family Software Tools Programmer’s Reference.
You can click Previous or Next to view the previous or next message. When 
there is no previous or next message, clicking these buttons closes the dialog 
box.

Viewing the Message and Error Count (RT Summary)
The RT Summary tab of the RT Mode screen shows the message and error count 
of all the RTs. You can set a name for each RT on the RT Summary Define screen. 
See Setting RT Names on page 3-13.

 Figure 3-12 RT Summary Screen
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Setting RT Names

You can set names for the RTs on the RT Summary tab.

To set RT names:

1. On the RT Mode screen (Figure 3-1), select Setup > RT Summary Define.
The RT Summary Define dialog box is displayed.

Figure 3-13 RT Summary Define Dialog Box

2. Type a name in each RT number field that you want to name.
3. Click OK.

The names are displayed on the RT Summary tab.

Clearing Messages
To clear the list of received messages:

• On the RT Mode screen (Figure 3-1), select File > Clear Screen.
All messages are cleared. 

Restarting the Module
To restart the module:

• On the RT Mode screen (Figure 3-1), select Run > Restart (or press F3).
The module is stopped and restarted, and the message and error counts at 
the bottom of the screen are set to 0.
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4 Sequential Monitor Mode

In Sequential Monitor Mode, the module acts as a Bus Monitor.

In this chapter:
The Sequential Monitor Mode Screen
Setting Options for Sequential Monitor Mode (Properties Tab)
Defining Triggers to Display/Store Messages (Properties Tab)
Saving/Loading the Sequential Monitor Mode Configuration
Starting/Stopping Sequential Monitor Mode
Viewing Message Details
Viewing the Message and Error Count (RT Summary)
Clearing Messages
Loading a Message File
Converting the Message File From Binary to ASCII
Restarting the Module
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The Sequential Monitor Mode Screen
To open the Sequential Monitor Mode screen:

• From the main screen menu bar, select Modules/Banks > Module/Bank # > 
Sequential Monitor Mode.
The Sequential Monitor Mode screen is displayed. When Sequential Monitor 
Mode is running, the Messages tab shows the messages received over the 
bus. Messages are updated in real time. The fields are described in 
Table 4-3. The Messages tab holds up to 199 messages. Older messages are 
overwritten as new messages are received.

Figure 4-1 Sequential Monitor Mode Screen

Setting Options for Sequential Monitor Mode (Properties Tab)
Sequential Monitor Mode settings are defined on the Properties tab of the 
Sequential Monitor screen. This section discusses all options on the Properties 
tab except for Triggers, which are discussed in Defining Triggers to Display/Store 
Messages (Properties Tab) on page 4-5.

To set options for Sequential Monitor Mode:

1. From the main screen menu bar, select Modules/Banks > Module/Bank # > 
Sequential Monitor Mode.
The Sequential Monitor Mode screen is displayed.
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Figure 4-2 Sequential Monitor Mode Screen

2. Click the Properties tab.

Figure 4-3 Sequential Monitor Mode Screen – Properties Tab
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3. Complete the fields, as described in Table 4-1. (Triggers are described in 
Defining Triggers to Display/Store Messages (Properties Tab) on page 4-5.)

Field Description

Mode Code 
Designation

Bit sequence in a subaddress that indicates that the message 
is a mode code:
• Both 0’s and 1’s – All 0’s or all 1’s specifies a mode code
• All 0’s – All 0’s specifies a mode code
• All 1’s – All 1’s specifies a mode code

Independent 
Monitor

Not supported on newer boards.

Broadcast Enabled 
(RT 31)

Whether to enable broadcast on RT 31.

Save to Whether to display the data on screen, save the data to a file or 
both.
• Screen Only
• Screen and File
• File Only

File Name to Save 
Data

Click Change and select a location and name for the data file.

Monitor Response 
Time

Time in μsecs after which if the RT does not respond it will be 
considered an error (4–32, default 14).

1760 Header 
Word Options
(1760 and MMSI 
only)

Whether messages will have a 1760 Header Word:
• Suppress/Disable the Feature
• User will set Header Word

Table 4-1 Sequential Monitor Mode Screen – Properties Tab
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Defining Triggers to Display/Store Messages (Properties Tab)
You can define up to two triggers to display and/or store messages. A trigger is 
based on specific bits being either 0 or 1 within either the Command Word or RT 
Status Word. When MerlinPlus receives a message with the specified Command 
Word or RT Status Word, MerlinPlus will follow the trigger rules and display and 
store messages.

To set triggers:

1. On the Sequential Monitor Mode screen, click the Properties tab.

Figure 4-4 Sequential Monitor Mode Screen – Properties Tab
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2. Complete the fields in the Triggers section of the Properties tab, as 
described in Table 4-2. (The other options on the Properties tab are 
described in Setting Options for Sequential Monitor Mode (Properties Tab) on 
page 4-2.)

3. In the table on the left side of the screen, define up to two triggers. For each 
bit that you want to set, click the X one or more times to select 0 or 1. Bits 
that are left as X can be either 0 or 1.

Saving/Loading the Sequential Monitor Mode Configuration
You can save the Sequential Monitor Mode configuration to a file and load the file 
later. The file includes the settings defined on all the tabs of the Sequential 
Monitor Mode screen.

To save the Sequential Monitor Mode configuration:

1. On the Sequential Monitor Mode screen (Figure 4-1), select File > Save 
Parameters.
The Sequential Mode Parameters dialog box is displayed.

Figure 4-5 Sequential Mode Parameters Dialog Box

2. Select a location to save the file.
3. In the File name field, type a name for the file.

Field Description

Trigger Type Trigger based on:
• Command Word
• RT Status Word

Trigger Mode Action to perform when trigger is received:
• Store All – display and/or store all messages; do not use 

triggers.
• Store Starting – display and/or store the trigger message 

and all following messages.
• Store Only – display and/or store only messages that match 

the triggers.

Table 4-2 Sequential Monitor Mode Screen – Triggers Section of Properties Tab
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4. Click Save.
The message file is saved.

To load a Sequential Monitor Mode configuration file:

1. On the Sequential Monitor Mode screen (Figure 4-1), select File > Load 
Parameters.
The Load Sequential Mode Parameters dialog box is displayed.

Figure 4-6 Load Sequential Mode Parameters Dialog Box

2. Select an SMP file, then click Open.
The Sequential Monitor Mode Parameters are displayed on the Parameters 
tab of the Sequential Monitor Mode screen (Figure 4-3).

Starting/Stopping Sequential Monitor Mode
You can start/stop Sequential Monitor Mode at any time. When you start 
Sequential Monitor Mode, the module acts as a Bus Monitor, and displays and/or 
saves messages that were received over the bus, according to the options specified 
on the Properties tab. See Setting Options for Sequential Monitor Mode (Properties Tab) on 
page 4-2.

To start Sequential Monitor Mode:

• On the Sequential Monitor screen (Figure 4-1), select Run > Start (or press F9).
MerlinPlus starts running Sequential Monitor Mode.

To stop Sequential Monitor Mode:

• On the Sequential Monitor Mode screen (Figure 4-1), select Run > Stop (or 
press F4).
MerlinPlus stops running Sequential Monitor Mode.
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Viewing Message Details
In Sequential Monitor Mode, there are three ways to view message details in real 
time: the Messages tab, the Message Information screen and the Real Time tab. 
The Messages tab shows basic information about each message on the bus. The 
Message Information screen shows the details of the message in the selected row 
on the Messages tab of the Sequential Monitor screen. The Real Time tab of the 
Sequential Monitor screen shows the details of up to 10 messages.

To view messages:

1. On the Sequential Monitor Mode screen (Figure 4-1), click the Messages tab.
When Sequential Monitor Mode is running, the Messages tab shows the 
messages received over the bus. Messages are updated in real time. The 
fields are described in Table 4-3.

Figure 4-7 Sequential Monitor Mode Screen – Messages Tab
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2. To view message details, double-click a message in Error column.
The Message Information screen is displayed.

Figure 4-8 RT Message Information Screen

The Message Information screen shows the details of the message in the 
selected row on the Messages tab of the Sequential Monitor screen. The 

Field Description

Num Message number.

Time (microsec) Timestamp of the message in μsec from the start of the 
module.

From Message from either BC or RT/subaddress.

To Message to either BC or RT/subaddress.

CW Command Word of the message.

CW2 Second Command Word of the message for RT to RT 
message.

WC Word Count. Number of Data Words in the message.

Bus
(not for MMSI)

Bus on which the message was transmitted.

Error Error status of the message.

Table 4-3 Sequential Monitor Mode Screen
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Message Information screen is updated in real time as new messages are 
received.
The top part of the screen displays the Command Word(s) and RT Status 
Word(s) of the completed message. The middle part displays the data. And 
the bottom part displays the Message Status Word that Excalibur stores for 
each message. 
The Message Status Word contains information about the completed 
message, including error information. The bits of the Message Status Word 
vary depending on the mode (BC/RT, RT or Sequential Monitor). For details 
on the Message Status Word in Sequential Monitor Mode, see 
Get_Next_Message_Px in the 1553Px Family Software Tools Programmer’s 
Reference.
You can click Previous or Next to view the previous or next message. When 
there is no previous or next message, clicking these buttons closes the dialog 
box.

Using the Real Time Tab

The Real Time tab of the Sequential Monitor screen shows the details of up to 10 
BC to RT or RT to BC messages, five on each tab: Real Time 1 and Real Time 2. 
These tabs are located on the right side of the screen. (Note that RT to RT 
messages are not supported on the Real Time tab.) 
You specify the messages that you want to display by providing the RT, 
subaddress and direction for each message. The Real Time tab is updated 
whenever the specified messages are received.
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To view messages using the Real Time tab:

1. On the Sequential Monitor Mode screen (Figure 4-1), click the Real Time tab.

Figure 4-9 Sequential Monitor Mode Screen – Real Time Tab

2. On the right side of the screen, click the Real Time 1 or Real Time 2 tab.
3. Click Select Msg.

The Define CW (Define Command Word) dialog box is displayed.

Figure 4-10 Define CW Dialog Box
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4. Complete the fields to specify the desired message, as described in 
Table 4-4, then click OK.

5. Repeat these steps for each message that you want to view in real time.
The Real Time tab shows the messages received over the bus. Messages are 
updated in real time. The fields are described in Table 4-5.

Viewing the Message and Error Count (RT Summary)
This RT Summary tab works the same in Sequential Monitor Mode as it does in 
RT Mode. See Viewing the Message and Error Count (RT Summary) on page 3-12. You can 
also set names for the RTs on the RT Summary tab. See Setting RT Names on 
page 3-13.

Clearing Messages
To clear the list of received messages:

• On the Sequential Monitor Mode screen (Figure 4-1), select File > Clear Screen.
All messages are cleared. 

Field Description

RT RT number.

SA Subaddress number.

Direction Direction of the message: 
• Receive
• Transmit

Table 4-4 Define CW Dialog Box

Field Description

CW Command Word of the message.

Time Tag Time stamp of the message in μsec from the start of the 
module.

SW RT Status Word.

WC Word Count. Number of Data Words in the message. 

Errors Number of messages with errors.

Count Number of times this message was received.

Status Error status of the message. Click in the Status field and use 
the Right Arrow key to see the entire list of errors.

Table 4-5 Sequential Monitor Mode Screen
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Loading a Message File
You can load previously saved messages that were saved by MerlinPlus. These 
messages were saved by selecting the save to file option on the Properties tab of 
the Sequential Monitor screen. See Setting Options for Sequential Monitor Mode 
(Properties Tab) on page 4-2. 

To load messages from a file:

1. On the Sequential Monitor Mode screen (Figure 4-1), select Setup > Read from 
File.
The Open Binary File dialog box is displayed.

Figure 4-11 Open Binary File Dialog Box

2. Select a DMP file, then click Open.
3. Select Options > Read from File > One-Shot or Continuous.
4. Select Run > Start (or press F9).

The messages are displayed on the Sequential Monitor Mode screen.

Converting the Message File From Binary to ASCII
You can convert the binary message file that was saved by MerlinPlus to a 
readable text file. The text file can be read in any text editor and can be opened in 
Excel by changing the file extension to CSV, then opening the file. The text file 
has a comma between each value and a header row.

To convert the message file to a text file:

1. On the Sequential Monitor Mode screen (Figure 4-1), select Options > Convert 
Binary->ASCII.
The Convert To ASCII dialog box is displayed.
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Figure 4-12 Convert To ASCII Dialog Box

2. Click the button next to the Binary file name field, then select the DMP file.
3. Click the button next to the ASCII file name field, then select a name and 

location for the output ASC file.
4. Select Write data as Hexadecimal or Write data as Decimal.
5. Click Convert.

The ASCII file is saved. The fields of the ASCII file are described in 
Table 4-6.

Field Description

No Message number.

Type Message type:
• BC to RT
• RT to BC
• RT to RT

Timetag Timestamp of the message in μsec from the start of the module.

MsgStatus Message Status Word that Excalibur stores for each message. The 
Message Status Word contains information about the completed 
message, including error information. The bits of the Message 
Status Word vary depending on the mode (BC/RT, RT or 
Sequential Monitor). 
For details on the Message Status Word in Sequential Monitor 
Mode, see Get_Next_Message_Px in the 1553Px Family Software 
Tools Programmer’s Reference.

CW1 Command Word of the message. For RT to RT messages, this is 
the first Command Word.

SW1 RT Status Word. For RT to RT messages, this is the RT Status 
Word from the transmitting RT.

WC1 Word Count. Number of Data Words specified in the Command 
Word of the message. For RT to RT messages, this is the Word 
Count in the first Command Word.

RT1 RT number specified in the Command Word of the message.

Table 4-6 ASCII File Fields
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Restarting the Module
To restart the module:

• On the Sequential Monitor Mode screen (Figure 4-1), select Run > Restart (or 
press F3).
The module is stopped and restarted, and the message and error counts at 
the bottom of the screen are set to 0.

SA1 Subaddress number specified in the Command Word of the 
message.

Bus
(not for MMSI)

Bus on which the message was transmitted.

CW2
(for RT to RT 
messages only)

Second Command Word of the message (to the transmitting RT).

SW2
(for RT to RT 
messages only)

Second RT Status Word (from the receiving RT).

WC2
(for RT to RT 
messages only)

Second Word Count. Number of Data Words specified in the 
second Command Word. 

RT2
(for RT to RT 
messages only)

RT number specified in the second Command Word of the 
message. 

SA2
(for RT to RT 
messages only)

Subaddress number specified in the second Command Word of 
the message.

data0 Data Word 0.

data1 Data Word 1.

data2 Data Word 2.

...

data31 Data Word 31.

Field Description

Table 4-6 ASCII File Fields (Continued)
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Appendix A MIL-STD-1553 Word Formats

Figure A-1 MIL-STD-1553 Word Formats

Note: T/R = Transmit/Receive 
P = Parity

Register
Bits

1553 Bit 
Times

Command 
Word

Data 
Word

Status 
Word

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20

5 1 5 5 1

16 1

5 1 3 1 11 1111 1

Sync RT Address T/R Word Count/
Mode Code

PSubaddress/Mode

Data PSync

Sync RT Address Reserved P

Message Error

Instrumentation

Service Request

Broadcast Command Received

Busy

Subsystem Flag

Dynamic Bus Control Acceptance
Terminal Flag
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Appendix B MIL-STD-1553 Message Formats

Figure B-1 MIL-STD-1553B Message Formats

Note: * = Response time 
 = Intermessage Gap time

BC to RT

RT to BC

RT to RT

Mode without 
Data (Mode 
Codes: 0 – 15)

Mode with Data – 
Transmit (Mode 
Codes: 16, 18, 19)

Mode with Data – 
Receive (Mode 
Code: 17)

Broadcast Mode 
without Data (Mode 
Codes: Broadcast 
0 – 15)

Broadcast BC 
to RTs

Broadcast RT 
to RTs

Broadcast Mode with 
Data (Mode Code: 
Broadcast 17)

Data 
Word

Transmit 
Command

Data 
Word

Status 
Word* Next 

Command

Data 
Word

Receive 
Command

Data 
Word

Data 
Word

Status 
Word* Next 

Command

Receive 
Command

Transmit 
Command

Data 
Word

Data 
Word

Status 
Word* Data 

Word
Status 
Word* Next 

Command

Mode 
Command

Status 
Word* Next 

Command

Mode 
Command

Status 
Word* Next 

Command
Data 
Word

Receive 
Command

Data 
Word

Data 
Word

Next 
Command

Data 
Word

Receive 
Command

Transmit 
Command

Data 
Word

Data 
Word

Status 
Word* Data 

Word
Next 
Command

*Mode 
Command

Status 
Word

Next 
Command

Data 
Word

Mode 
Command

Next 
Command

Mode 
Command

Next 
Command

Data 
Word

Data 
Word



The information contained in this document is believed to be accurate. How-
ever, no responsibility is assumed by Excalibur Systems, Inc. for its use and 
no license or rights are granted by implication or otherwise in connection 
therewith. Specifications are subject to change without notice.
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